Official support hours: from 9 AM — 6 PM Monday to Friday (GMT +2).
The support staff may not reply on technical inquiries on weekends; all requests will be answered necessarily during working days. Reply time: depending on the complexity of your issue, the answer can be provided between a few hours up to 48 hours. In the particular instances we will notify you if extra time will be required to solve the issue.

Ошибки PHP при использовании шаблона Kneat

9 months 7 hours ago #1079 by Андрей Лукин
Добрый вечер!
Купил Ваш шаблон Kneat, установил.
И возле одного моего модуля появились сообщения об ошибках в PHP коде.


Notice: Only variables should be assigned by reference in /home/m/moysun/secrets-game-rf/public_html/modules/mod_custom_advanced/mod_custom_advanced.php(69) : eval()'d code on line 12 Notice: Use of undefined constant stCol - assumed 'stCol' in /home/m/moysun/secrets-game-rf/public_html/modules/mod_custom_advanced/mod_custom_advanced.php(69) : eval()'d code on line 62

При установке других шаблонов такого не возникает.
Как это поправить?
Attachments:
The topic has been locked.
9 months 6 hours ago #1080 by Eugene S.
Андрей, здравствуйте.
Это не ошибка, а нотис (notice). Ошибка в скрипте - это fatal error. Нотис - предупреждение, рекомендация поправить кое-что, но без этого будет работать.
Подробнее можно почитать здесь .
Можно изменить уровень показа ошибок: Система - общие настройки - сервер - Сообщения об ошибках и далее выбирайте параметр "простой" или "нет".


Если все же хотите исправить сам нотис, то нужно копать. В нашем шаблоне нет таких проблем, так как на рабочем полигоне выставили максимальный показ ошибок. Судя по скриншоту, который Вы привели, система обнаруживает ошибку в модуле: mod_custom_advanced. Как я понимаю, это какой-то сторонний модуль для вставки произвольного кода?
Например, PHP кода. Если это так, то нужно смотреть содержимое модуля (его контент) и искать решение в этом направлении. Вероятно, конфликт скриптов, либо на Вашем сайте используется устаревшая версия PHP или какие-то конструкции кода, несовместимые с новой версией PHP (проще говоря, старые модули).

Like our extensions for Kunena?
Add your voice to the JED listing with a 100 score review: bit.ly/2cIg8pF
Thanks!
Attachments:
The topic has been locked.
Moderators: Eugene S.