Official support hours: from 9 AM — 6 PM Monday to Friday (GMT +2).
The support staff may not reply on technical inquiries on weekends; all requests will be answered necessarily during working days. Reply time: depending on the complexity of your issue, the answer can be provided between a few hours up to 48 hours. In the particular instances we will notify you if extra time will be required to solve the issue.

×
RND Kglorious released - new template for Kunena 5 (17 Jul 2017)

RND KGlorious is a high class template that was developed using modern technologies and opens new series of Kunena templates. RND Kglorious has designed as ultimate solution (Kunena and Joomla template) to create standalone-like forums.

SSL, mixed content

2 years 9 months ago #77 by shimei
Hi,

I just realized my issue only is with the Roundtheme template I am using. My forums shows mixed content so it fails SSL while using Firefox. It appears that the mixed content is do to this, as seen in Firefox console: Blocked loading mixed active content " fonts.googleapis.com/css?family=roboto,H...eva,Arial,sans-serif "

I definitely need some help here, or I'll have to turn back to the default template for Kunena.

www.christforums.org/forum/index

William

2 years 9 months ago #79 by shimei
Edit: I found A file, rnd_kascetic/initialize.php

And saw in line 65 where it said: $document->addStyleSheet( ' fonts.googleapis.com/css?family='.$googlefont .'' );

I changed that to: $document->addStyleSheet( ' fonts.googleapis.com/css?family='.$googlefont .'' );

but now, although it shows SSL compliant, a 400 bad request is showing in Firefox console.

2 years 9 months ago #80 by sulpher
Hello William,
The problem you've described above is related to wrong settings with font family.
You don't need to change anything in the code of template files like initialize.php :-) Since the problem is not in the template itself, it's happen because of wrong syntax of font family. So, please check out googlefont= param in the template back-end settings in Kunena > Templates.

Kascetic template uses 'Lato', sans-serif font by default, but you've replaced it to Roboto with a wrong syntax.
The correct param should be like this:
googlefont="Roboto:400,700"
font="'Roboto', sans-serif"
fontheaders="'Roboto', sans-serif"

Please check out your template settings. Since you're using another external fonts UbuntuRegular and OrbitronMedium, you may include them instead of Roboto.

Yesterday we've released updates of all templates . I recommend you to update template to its latest version. Please note that back-end settings will be overwritten (params.ini file) and you have to set up settings once again, so you may just make back-up of current params.ini file and replace it after updating. Also if you changed something in the template, it may be lost because of files overwriting.

If you get a difficulty with solving this problem, you may provide credentials to your website and I'll make a fix.

Like our extensions for Kunena?
Add your voice to the JED listing with a 100 score review: bit.ly/2cIg8pF
Thanks!

Partners